«phpClub» — архив тем ("тредов"), посвящённых изучению PHP и веб-технологий.
Аноним 2019/01/22 15:20:17  №1332703 1
Фреймворк yii2. Такая проблема: в верстке используется более свежая версия jQuerty, чем в фреймворке. В ассете отключаю jQuery, которая идет с вёрсткой - верстка корректно работает (меню сворачивается в бургер и работает), но не работает валидация от Yii. Делаю наоборот - верстка перестает корректно работать, но валидация отрабатывает своё. Какими путями можно решить эту штуку?
Ответы: >>1332726 >>1332734
Аноним 2019/01/22 16:00:34  №1332726 2
>>1332703

Правильнее всего переделать верстку на использование jQ от Yii. Либо мучаться с jQuery.noConflict(), загружая 2 копии библиотеки и используя в верстке приватную копию.