«phpClub» — архив тем ("тредов"), посвящённых изучению PHP и веб-технологий.
Аноним 2020/03/26 08:12:27  №1642975 1
HELP
Пытаюсь ui в лару, выдает вот такую хуйню. Я может дебил конченный, уже 2 часа гуглю, но проблема не проходит:

composer require laravel/ui --dev
Using version ^2.0 for laravel/ui
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: remove laravel/framework v6.18.3
- Conclusion: don't install laravel/framework v6.18.3
- laravel/ui 2.x-dev requires illuminate/console ^7.0 -> satisfiable by illuminate/console[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.2.0, v7.2
.1, v7.2.2, v7.3.0].
- laravel/ui v2.0.0 requires illuminate/console ^7.0 -> satisfiable by illuminate/console[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.2.0, v7.2.
1, v7.2.2, v7.3.0].
- laravel/ui v2.0.1 requires illuminate/console ^7.0 -> satisfiable by illuminate/console[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.2.0, v7.2.
1, v7.2.2, v7.3.0].
- don't install illuminate/console 7.x-dev|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.0|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.1|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.2|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.3|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.4|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.5|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.6|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.7|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.0.8|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.1.0|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.1.1|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.1.2|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.1.3|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.2.0|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.2.1|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.2.2|don't install laravel/framework v6.18.3
- don't install illuminate/console v7.3.0|don't install laravel/framework v6.18.3
- Installation request for laravel/framework (locked at v6.18.3, required as ^6.2) -> satisfiable by laravel/framework[v6.18.3].
- Installation request for laravel/ui ^2.0 -> satisfiable by laravel/ui[2.x-dev, v2.0.0, v2.0.1].


Installation failed, reverting ./composer.json to its original content.
Ответы: >>1643024
Аноним 2020/03/26 09:44:25  №1643024 2
>>1642975
Кароче в пизду я просто перенесу всё в новый проект, там всё работает. Надо было сразу так сделать =)