«phpClub» — архив тем ("тредов"), посвящённых изучению PHP и веб-технологий.
Аноним 2021/01/26 04:15:40  №1921900 1
asasas.png (8, 969x369)
369x969
Прорабатываю курс по ларавелу. Там начало на 5.7, потом переход на 5.8, и вот теперь на 6.0. А у меня ошибка. Вот поставил свежий Ларавел 6.20, добавляю аутентификацию - а она не ставится. Ничего путного не нагуглил. Что сделать, чтобы заработало?
Ответы: >>1921943
Аноним 2021/01/26 06:43:08  №1921943 2
>>1921900
Хоть бы на гитхаб страничку пакета зашел и прочел предупреждение...

Почему в пхп треде люди настолько нелюбознательные?
Ответы: >>1922461
Аноним 2021/01/26 15:40:03  №1922461 3
>>1921943
Так в том-то и дело, что я не понимаю, что вообще тут происходит. Требуется пакет ххх, он найден, но конфликтует с другим пакетом. И что вообще в таких ситуациях делать? Я не сеньёр-помидор и не мидл, я просто хочу пересесть с вордпресса и голого пхп на ларавел. Смотрю уроки, выполняю то, что в них описано.

То есть, мне нужно было зайти на https://github.com/illuminate/console, увидеть, что там пусто, зайти на https://github.com/laravel/ui, увидеть табличку "Supported Versions", сообразить, у меня ставится 3.2, а с Ларавелом 6 совместима только 1.х, понять, как указывать композеру номер версии и написать composer require laravel/ui "1.*" и после этого получить установленный с пакет? Шаманство какое-то. Везде кричат, что композер это круто и рулез форева. А на деле даже не может выбрать совместимые пакеты. Как так-то?